[legup-dev] Unable to run programs on Altera DE2

Aravindkumar Rajendiran rajendiran.aravind at yahoo.com
Sat Dec 3 18:09:41 EST 2011


Hi,
I am trying to use the unmodified tigerMips from the legup project. I followed the steps as specified in the legup-1.0/tiger/processor/README.
- To program executable, first synthesize and program this project to DE2

- Then, run "legup/tiger/windows_tools/tiger_tools/MIPS Communication Server.exe" and click connect
- Then, run "legup/tiger/windows_tools/run.bat" to program desired ELF file

I am trying to run a simple program that changes the SSDs to display a few characters (see attachement). 

I did "run.bat Prog.elf", and it tries to load to ".text" section at the correct address. However, nothing happens beyond that. 

I followed the same procedures and tried to load the original TigerMips from http://www.cl.cam.ac.uk/teaching/0910/ECAD+Arch/mips.html. The same program seems to run on the original TigerMips core and I can see the characters appear on the Altera DE2 board.

I was wondering if there is something else that I need to do to get the unmodified TigerMips from the legup project to run a program on the board? Any help would be appreciated.

Thanks in advance,
Aravind
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.legup.org/pipermail/legup-dev/attachments/20111203/2d8ae9f4/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.S
Type: application/octet-stream
Size: 477 bytes
Desc: not available
URL: <http://lists.legup.org/pipermail/legup-dev/attachments/20111203/2d8ae9f4/attachment.obj>


More information about the legup-dev mailing list