[legup-dev] Unable to run programs on Altera DE2

Andrew Canis andrewcanis at gmail.com
Mon Dec 5 19:55:49 EST 2011


Looking at the SOPC builder for the processor, the base address of the
hex display is F0000820.
But you're writing to address: 0xF0000810. Could that be the problem?

On Sat, Dec 3, 2011 at 6:09 PM, Aravindkumar Rajendiran
<rajendiran.aravind at yahoo.com> wrote:
> Hi,
> I am trying to use the unmodified tigerMips from the legup project. I
> followed the steps as specified in the legup-1.0/tiger/processor/README.
> - To program executable, first synthesize and program this project to DE2
> - Then, run "legup/tiger/windows_tools/tiger_tools/MIPS Communication
> Server.exe" and click connect
> - Then, run "legup/tiger/windows_tools/run.bat" to program desired ELF file
>
> I am trying to run a simple program that changes the SSDs to display a few
> characters (see attachement).
>
> I did "run.bat Prog.elf", and it tries to load to ".text" section at the
> correct address. However, nothing happens beyond that.
>
> I followed the same procedures and tried to load the original TigerMips
> from http://www.cl.cam.ac.uk/teaching/0910/ECAD+Arch/mips.html. The same
> program seems to run on the original TigerMips core and I can see the
> characters appear on the Altera DE2 board.
>
> I was wondering if there is something else that I need to do to get the
> unmodified TigerMips from the legup project to run a program on the board?
> Any help would be appreciated.
>
> Thanks in advance,
> Aravind
>
>
> _______________________________________________
> legup-dev mailing list
> legup-dev at legup.org
> http://lists.legup.org/listinfo/legup-dev
>


More information about the legup-dev mailing list